2 mb
3115 dls
October 24, 2007
These 24 ships should work in the metaverse since no mods were installed during the design and mods were deactivated in the main menu. Please read the readme.txt for further informations and how to install. These ships will also work in regular games.

Requirements: GalCiv2 Dark Avatar 1.6 (i don't know if it will work on older versions too), Collectors Edition Structures if you don't have the latest patch.